Glossary

active pane
At any time, there will be a pane in focus in the program, which is termed the active pane. The File menu, toolbar, and Control Panel will all be furnished with options specific to the active pane’s pane type.
alias
An alternative name given to a plot item or an element of a plot item. When an item has an alias, the alias, rather than the item’s base name, is used as the text label that identifies the item in the plot’s legend.
attached faces
Attached faces are grid faces of separated sub-grids that are attached or joined together. Attached faces must be coplanar and touching, but gridpoints on each face do not have to match. Sub-grids of different zone densities can be attached.
attribute
An attribute (sometimes also called a “switch”) is a control that affects the display of a plot item by controlling an aspect of the item’s appearance or display (e.g., transparency, color, size). In PFC, each plot item has a list of attributes that affect its appearance.
bitmap
A bitmap (more correctly and broadly termed a raster image) is a rectangular image composed of pixels. There are many bitmap file formats. PFC can generate Portable Network Graphics (PNG) and Windows Bitmap (BMP) file types. Contrast this to vector image.
boundary condition
A boundary condition is the prescription of a constraint or controlled condition along a model boundary (e.g., a fixed displacement or force for mechanical problems, an impermeable boundary for groundwater flow problems, adiabatic boundary for heat transfer problems, etc.).
bundle file
A bundle file is generated using the Bundle tool (Tools ‣ Bundle). It gathers the project file, all input files tracked by it, and the record stripped from all model save states. This is a simple and convenient method for archiving projects. It is also a very useful attachment to technical support requests, since all resources needed to re-create the reported issue are made available to the support provider.
CALL
CALL is a PFC command (available either at the command prompt or via the File menu) that opens and executes a data file in PFC.
command prompt
The bottom part of the i Console pane, composed of a prompt (pfc> in PFC; flac3d> in FLAC3D) and an edit field where commands may be entered.
command prompt
The command prompt is used to enter commands in PFC, line by line. It appears in the bottom of the Console pane. PFC output responses to commands entered at the prompt are displayed in the Console pane above it.
console
A generic reference to the i Console pane. The term refers to any text-based command-processing application. As command-driven software, Itasca programs have a console. In some cases it may be referred to generically this way in the program documentation (“… in the console …”).
Console (pane)
The Console pane contains the command prompt and the display area appearing above it. Output messages from PFC appear in the display area as commands at the prompt (or from data files) are processed. Unlike View and Editor panes, there is only one instance of the Console pane in the PFC interface. See the topic Overview: Console for further information.
Console pane
This pane is divided into two parts. The bottom of the pane is the command prompt, where users may enter commands one at a time. The upper part of the pane (variously referred to as the output, the output window, the console output, etc.) echoes commands and prints written output resulting from command processing. The Options dialog provides options for which output and how much of it will be displayed in the output.
constitutive model
The constitutive (or material) model represents the deformation and strength behavior prescribed to the zones in a FLAC3D model. Several constitutive models to assimilate different types of behavior commonly associated with geologic materials are available in FLAC3D. Constitutive models and material properties can be assigned individually to every zone in a FLAC3D model.
Control Panel
The Control Panel is a pane that contains tools for working with Views. These tools are grouped into control sets. In PFC 6.0, the Control Panel is used only in conjunction with View panes or the Extrusion pane.
control set
The Control Panel has three control sets available to it: Plot Items, which is used to specify plot items (and their switches) for display in a View pane; View Information, which displays model information relative to the current location of the mouse cursor; and View Controls, which provides tools for manipulation (zoom, rotate, magnify etc.) of the model view. Display of each control set within the Control Panel may be toggled off/on. In addition, the control sets may be subdivided into components that may be displayed/minimized within the Control Panel.
cycle
A cycle refers to the unit of model time it takes to complete the calculations in one timestep. Also may be referred to as “step.”
data file
Program commands may be issued “interactively” at the command prompt, or via a data file. The data file is a formatted ASCII file created by the user, which contains the set of commands that represents the problem being analyzed. In general, creating data files is the more efficient modeling method. Data files are opened and the commands within them are executed by the program using the program call command, or via the File ‣ Open Item… menu command. Though data files can have any file name and any extension, it is recommended that a common extension (e.g., “.F3DAT” for FLAC3D data input commands or “.P3FIS” for FISH function statements in PFC3D) be used to distinguish these files from other types of files.
data file
A text file containing PFC commands. As one data file can call another (via the CALL command or FISH), several data files may be linked. See the topic The Editor Pane for information on working with and executing data files.
dock
The term “dock” means to place a pane or toolbar in a fixed location within the interface. See also “float.”
dynamic solution
For a dynamic solution, the full dynamic equations of motion (including inertial terms) are solved; the generation and dissipation of kinetic energy directly affect the solution. Dynamic solutions are required for problems involving high frequency and short duration loads (e.g., seismic or explosive loading). The dynamic calculation is an optional module for FLAC3D (see Dynamic Analysis).
Editor (pane)
The Editor pane provides the facility to work with (create, edit, validate) data files. Each instance of the Editor pane holds one file; multiple instances of the pane (and thus multiple files) may be open at once. Any text file may be loaded into the pane. See the topic Overview: Editor for more information.
element
See zone.
finite volume grid
The finite volume grid is an assemblage of one or more finite volume zones across the physical region that is being analyzed. Another term for grid is mesh. The finite difference grid also identifies the storage locations of all state variables in the model. The procedure followed in FLAC3D is that, in general, all the vector quantities (e.g., forces, velocities, and displacements) are stored at gridpoint locations, while all scalar and tensor quantities (e.g., stress and material properties) are stored at zone centroid locations. See The Lagrangian Finite Volume Grid topic for more information.
FISH (file)
FISH is the embedded scripting language of PFC. It may be used to define new functions and variables to extend PFC’s capabilities and to create user-defined features. A FISH file stores one or more FISH functions that may be run by command from a data file.
fish i/o file
A user-written FISH function may create, write, and read files (see the FISH Functions section for file input/output) of two forms. If the binary form is selected, the exact binary representation of a FISH variable is stored on file. If the ASCII form is selected, numeric or character data may be written, or read from, a file. The latter form is a useful way to process ASCII data in a nonstandard way on file.
float
The term “float” means to place a pane or toolbar in a detached position “above” or “outside” the main PFC window. Also see “dock.”
geometry file
A geometry file is a set of nodes, edges, or polygons in space. Sometimes this is referred to as CAD data. This data could have originated from other sources, or it could have been generated by FLAC3D. FLAC3D currently recognizes three geometry file formations: DXF, STL, or GEOM. The first two are industry standards, the last is an Itasca-specific format that preserves object meta-data (FISH extra variable assignment and/or group assignments).
grid (file)
A grid file is an ASCII file containing the description of coordinates of gridpoints, which gridpoints make up each zone, and which zones make up each group. It may be imported into PFC to make a grid (see next).
grid (term)
A grid is a geometric domain composed of zones and is the principal object in a PFC model. Grids may be created using PFC commands or imported from a grid file using the File menu.
gridpoint
Gridpoints are associated with the corners of the finite difference zones. There are four, five, six, seven, or eight gridpoints associated with each polyhedral zone, depending on the zone shape. A set of x-, y-, z-coordinates is assigned to each gridpoint, thus specifying the exact location of the finite difference zones. Other terms for gridpoint are nodal point and node, but these are generally reserved for structural elements for clarity.
group
A group in a FLAC3D model refers to a name that can be assigned to one or more objects. Group names are assigned in a category, called slots, with the constraint that in a given object, each slot can only have one group assigned at a time. An object may have many different group names, each in different slots. As compared with a range, groups will always refer to specific model objects. Groups provide a way to persistently “name” parts of the model, and subsequently operate with ease on those parts of the model by applying that name to the range keyword in commands (e.g., consider zone cmodel assign mohr-coulomb range group "Layer1", which, as can be guessed, assigns the Mohr-Coulomb model to the zones in the group “Layer1”).
history file
A history file is a formatted ASCII file created at the user’s request when issuing the command history export command. The user may specify a name for the file using the file keyword of the command; if not, the default name “FLAC3D.HIS” is used. Commands for creating history files may be issued interactively or within data files. A record of the history values is written to the file, which can be examined using any text editor that can access formatted ASCII files. Alternatively, the file may be processed by a commercial graph-plotting or spreadsheet package.
id number

Individual elements of a FLAC3D model are identified by identification (ID) numbers. Almost all model elements have ID numbers, including interfaces, gridpoints, zones, histories, tables, and structural element entities (i.e., beams, cables, piles, shells, liners, and geogrids). These are unique numbers that are assigned by the code allowing the user to identify specific elements in a model. Elements that have IDs supply a list keyword that is used to return ID-sorted data about the object. can’t use the following until it is common: (for example, try :cmd:’zone.list.information’).

Component identification (component-id) numbers are also assigned to individual elements of a structural element entity. A unique component-id number is created for each node, element, and node/grid link that make up a beam, cable, pile, shell, liner, or geogrid entity.

initial conditions
This is the state of all variables in the model (e.g., stresses or pore pressures) prior to any loading change or disturbance (e.g., excavation).
interface
An interface is a connection between sub-grids that can separate (e.g., slide or open) during the calculation process. An interface can represent a physical discontinuity such as a fault, contact plane, or interface between two different materials.
item
“Item” is a term that refers generically to any individual file used in, or created by, a PFC project. This may include data files, FISH files, SAV files, plot files, grid files, and more. See Overview: Projects for an introduction to projects. See The Project Pane for information on working with projects.
large strain/small strain
By default, FLAC3D operates in small-strain mode; gridpoint coordinates are not changed even if computed displacements are large (compared to typical zone sizes). In large-strain mode, gridpoint coordinates are updated at each step according to computed displacements. In large-strain mode, geometric nonlinearity is possible.
layout
The current configuration of the panes, menus, and toolbars in PFC is the “layout.” The layout is saved with the project; PFC restores that layout when the project is (re)opened. The current layout may be saved by the user and subsequently applied to a project that uses a different layout. See the Layouts and Working with Panes topics for more information.
legend
All plots contain a legend. The information appearing on the legend is configured through the Legend plot item.
Listing (pane)
A Listing pane is created any time a LIST command is used that generates textual output exceeding a specified number of lines. That threshold value is set in the Listings section of the Options dialog. Output under the threshold is displayed in the Console; output over the threshold is put into a new, automatically created Listing pane.
log file
The log file is a formatted ASCII file that captures all output text from the Console pane. The log file is useful in providing a record of the FLAC3D work session; it also provides a document for quality-assurance purposes. The file is created/maintained if the command program log is set on. The user may supply a file name using the program log-file command; if the command is not given but logging is on, the default file name “FLAC3D.LOG” will be used.
main menu
There is only one menu in the program, located immediately beneath the program title bar.
mesh
See finite volume grid.
mesh file
A mesh file is a file format that specifies a discretization of space into gridpoints and zones (or nodes and elements if using typical finite-element parlance). FLAC3D defines it’s own mesh formation, F3GRID. FLAC3D can also directly import ANSYS (.LIS) and ABAQUS (.INP) formats.
model
The model (or FLAC3D model) is created by the user to simulate a physical problem. When referring to a FLAC3D model, the user implies a sequence of FLAC3D commands (see the FLAC3D section) that define the problem conditions for numerical solution.
model boundary
The model boundary is the periphery of the finite difference grid. Internal boundaries (i.e., holes within the grid) are also model boundaries.
model state

The model state is all the information the program holds in computer memory at this moment regarding the computational model. A save file — which may also be called a saved state or sav file — is a stored model state. Also see program state and project state. The model state contains the following.

  • all model objects and all custom data stored with them (in extra variables)
  • all auxiliary entities (geometries, DFNs, etc.)
  • all intermediate model objects (extrusion sets and building block sets in FLAC3D, clump templates in PFC, etc.)
  • all current FISH symbols and values

When the model state is cleared by use of the model new command, all of the above is completely cleared from memory.

names
For certain types of model element objects (like histories, tables, or interfaces) it is convenient to assign a clear short user-assigned name to an object so it can be referred to later. In general, this is done using a name, which is normally assigned when the object is created. A name is meant to be a short identifying string, although technically it can be of any length. As a special case, an integer can be used on the command line as a name, in which case it will be converted automatically into a string.
null zone
Null zones are zones that represent voids (i.e., no material present) within the finite difference grid.
pane
A pane refers to any “page” in the program that appears as a rectangular container that is furnished with its own title bar and open/close controls. Each pane type is designed to perform a specific function.
pane menu
The set of commands available for the active pane accessed from the pane menu button ( pmen ) at the right end of the active pane’s title bar. The commands available from the menu vary with each pane type.
pane type
The common pane types are: Console, Project, Editor, View, Listing, State Record, IPython Console. The Extrusion and Building Block panes are specific to FLAC3D. The closure state of pane types varies, as does access. Editor, View, and Listing panes, of which there may be multiple instances, are accessed from the Documents menu. All other pane types, of which there is only ever one instance, are accessed from the Panes menu. CS: when done come back here and make each pane name a link to the main page for that pane
plot (file)
A “plot file” is a binary file that stores all plot settings of a given plot. Note that the model state information is not saved in the file, so the same plot file may be used in conjunction with multiple SAV files to create the same representation of the model at different stages of cycling. A plot file is opened using the “Open Item…” command on the File menu. Depending on the user’s needs, there are different ways of holding on to plot information for future use. See Plot Files vs. (Plot) Data Files for more information.
plot (term)
A plot is a visual representation of the PFC model contained in a View pane (to avoid confusion, we do not use the term “view” to refer to a model visualization since it is the term used to name the pane type that contains the plot). Typically, plots are composed of plot items and a legend. In PFC documentation, when plot is capitalized (PLOT) it refers to the PLOT command, which may be used at the command prompt in the Console to create or manipulate a given view.
plot item
A plot item is any single visual element that may be added to a plot. The complete list of plot items available in PFC appears in the List tab of the Plot Items control set in the Control Panel.
primitive
A templatized shape that can be used with the zone create command to create a range of FLAC3D grids. The shapes are keywords of the command; refer to the reference information on the command for details on primitives.
program state
The program state is all information, settings, or default behaviors that are specific to the PFC program itself. This information does not affect (nor is it contained in) either the project state or the model state. Most program state attributes may be set using the Options dialog.
project
A project refers to the collection of data files and other inputs, and save files and other outputs, that comprise a FLAC3D model. A project so-defined is stored in a project file. The terms “project” and “project file” are so nearly synonymous that they are likely to be used somewhat interchangeably in this documentation.
Project (pane)
The Project pane tracks the input files (data files) and output (model state (SAV)) files created in a single modeling run. In addition to tracking these items, the pane may be used to open and close files, to determine which files are available and to navigate between them, and more.
project (term)
The project is a record, kept in a file, that stores/tracks the items that make up a PFC modeling simulation. Project items are not embedded in the project; they are stored as separate files. See Overview: Projects for a complete description. See Project Pane to work with projects and items.
project file
The project file represents all the files and user interface elements involved in a given FLAC3D project, which may involve many different specific models and model states. The data in a project file is separate from the model state and is not affected by a model new or model restore. The project file stores the user-interface layout, the plot files, the data files being edited, and the list of data and save files that have been used or created for the project. See Projects.
project state
The project state is all information pertinent to the current project (that is, anything that would be recorded in the project file). The project state is a kind of “wrapper” that may be tracking one or more model states and the input files used to create it/them. Note that the project may track multiple model states, but only one model state may be currently open in PFC at a time.
range
A range in a FLAC3D model is a filter that restricts the operations of a command to objects that fall within the definition of the filter. A range may or may not be associated with specific model objects (for example, a range specified in terms of ID numbers or groups will be associated with specific model objects, but a range specified in terms of x-, y-, and z-coordinates remains fixed in space, so the objects within it at one point of model processing may not be the same as the objects in it at a later point).
range element
A criterion in a range. Any range will have at least one range element, but may be composed of many range elements, may be designed to be a union or an intersection of the range elements supplied, and may invert any element provided by appending not at the end of the range element’s specification.
result file
A result file is a smaller version of a save file (see above) containing only specific user-specific pieces of information about the model. Since they are much smaller (generally around 5% of the size of a save file) many more of them may be created without undue use of storage. A result file may be imported, overwriting the current model state, so that the contents can be visualized. Result files may be automatically output at user-specified intervals during the calculation.
SAV file
See save file. The file containing the model state at a given moment in model processing. Multiple SAV files may be generated for a computational model during a simulation.
save file
A save file (interchangeably referred to as a SAV file or saved state) is a binary file containing the values of all state variables and user-defined conditions up to the current moment of program execution. The primary reason for creating save files is to allow one to investigate the effect of parameter variations without having to rerun a problem completely. A save file can be restored and the analysis continued at a subsequent time (see the model restore command). Normally, it is good practice to create several save files during a program run. CS: redo the next two statements after the section on state record is built) Save files are created with the :cmd:-model.save- command; if this command is given without a :lkwd:`filename keyword, the default name “FLAC3D.F3DSAV” will be supplied.` The term model state may also be used to refer to a saved state (in addition to being, more specifically, the exact state of the model).
saved state
See save file.
State Record (pane)
The State Record pane tracks the model state. It provides two views. The Record of Input view displays the commands that make up the current model state. The List of Input Files view shows the files that have been used to make up the current state.
state record (term)
A state record is a transcription of the steps that have gone into the creation of the current model state. The state record is tracked in the State Record pane (see above), and may be exported for later use. An exported state record may be loaded into PFC and should, in all cases, create and return the entire model to its exact state at the moment the file was created.
static solution
A static or steady-state solution is reached in FLAC3D when the rate of change of kinetic energy in a model approaches a negligible value. This is accomplished by damping the equations of motion. At the conclusion of the static solution stage, the model will either be at a state of equilibrium or at a state of steady flow of material if a portion (or all) of the model is unstable (i.e., fails) under the applied loading conditions. This is the default calculation in FLAC3D. Static mechanical solutions can be coupled to transient groundwater flow or heat transfer solutions. (As an option, fully dynamic analysis can also be performed by inhibiting the static solution damping.)
step
Because FLAC3D is an explicit code, the solution to a problem requires a number of computational steps. During computational stepping, the information associated with the phenomenon under investigation is propagated across the zones in the finite difference grid. A certain number of steps is required to arrive at an equilibrium (or steady-flow) state for a static solution. Typical problems are solved within 2000 to 4000 steps, although large complex problems can require tens of thousands of steps to reach a steady state. When using the dynamic analysis option, model step refers to the actual timestep for the dynamic problem. Other terms for step are timestep and cycle.
structural element

Two types of structural elements are available in FLAC3D. Two-noded, linear elements represent the behavior of beams, cables, and piles. Three-noded, flat triangular elements represent shells, liners, and geogrids. Structural elements are used to simulate the interaction of structural support within a soil or rock mass. Nonlinear material behavior can be represented with some of the elements.

Each structural element entity (beam, cable, pile, shell, liner, or geogrid) is composed of three components: nodes; individual elements; and node/grid links. The characteristics of each of these components distinguish the behavior of the beam, cable, pile, shell, liner, and geogrid entities.

subgrid
The finite difference grid can be composed of sub-grids. Sub-grids can be used to create regions of different shapes in the model (e.g., a dam sub-grid can be placed on a foundation sub-grid).
switch
See the term attribute.
table file
A table file is a formatted ASCII file created by exporting a table using the table export command. This table may be modified by the user and imported into another model state using the table import command. The table file format is simple and easy to create from spreadsheets or other ASCII data. It specifies a single sequence of (x,y) value pairs, either at regular or irregular x-intervals.
title bar
All panes in PFC and the program’s main window have a title bar. The title bar appears at the top of the pane, contains a label that indicates the content of the pane and provides controls to minimize/hide, maximize/restore and/or close the window (which of these controls is present depends on the pane’s type).
toolbar
There is one toolbar in the program. It appears adjacent to the main menu. It can be repositioned as desired within the program’s main window. The contents of the toolbar are contextual to the currently active pane, and will change when the active pane type changes. Each pane also allows for a local copy of the toolbar be loaded directly beneath its title bar, via the pane menu.
unbalanced force
The unbalanced force indicates when a mechanical equilibrium state (or the onset of plastic flow) is reached for a static analysis. A model is in exact equilibrium if the net nodal-force vector (the resultant force) at each gridpoint is zero. The maximum nodal-force vector is monitored in FLAC3D and printed to the screen when the model step or model solve command is invoked. The maximum nodal force vector is also called the unbalanced or out-of-balance force. The maximum unbalanced force will never exactly reach zero for a numerical analysis, but the model is considered to be in equilibrium when the maximum unbalanced force is small compared to the total applied forces in the problem. If the unbalanced force approaches a constant nonzero value, this probably indicates that failure and plastic flow are occurring within the model. When a gridpoint is fixed in a given direction, the component of the unbalanced force in that direction is equivalent to the reaction force.
user data file
FLAC3D currently supports three types of user-defined data types. Scalar fields, vector fields, and tensor fields. These data types support both export and import into custom ASCII file formation, via the data scalar import or data scalar export commands (for example). These are used primarily to record possible model data or to compare against data generated outside FLAC3D (like seismic events imported as scalar data).
vector image
A vector image is any kind of image that uses mathematically described primitives for representation. The most immediate advantage of vector images over raster (or “bitmap”) images is that vectors are easily scalable since they do not have a “resolution” that is device-dependent. PFC can produce two types of vector images, Drawing Exchange Format (DXF) and Virtual Reality Markup Language (VRML). It also produces two types of compound images (vector with the ability to include/embed raster content), PostScript (PS) and Scalable Vector Graphics (SVG).
View (pane)
A View pane is a pane that contains a plot. “Plot” refers to the image that appears within a View.
zone
The finite difference zone is the smallest geometric domain within which the change in a phenomenon (e.g., stress versus strain) is evaluated. Polyhedral zones of different shapes (e.g., brick, wedge, pyramid and tetrahedral-shaped zones) are used to create models and can be viewed upon plotting. Each polyhedral zone contains two overlaid sets of five tetrahedral subzones, but the user is not normally aware of these. Another term for zone is element, but this is generally reserved for structural elements for clarity.
zone
A zone is the smallest geometric domain within which the change in a phenomenon (e.g., stress versus strain) is evaluated in PFC. Polyhedral zones of different shapes (e.g., brick, wedge, pyramid, and tetrahedral-shaped zones) are used to create models. Another term for zone is “element.”

Nomenclature

FLAC3D uses nomenclature that is consistent, in general, with that used in conventional finite difference or finite element programs for stress analysis. The basic definitions of terms are reviewed here for clarification. The figure below illustrates the FLAC3D terminology.

../../../../_images/nomenclature01.png

Figure 1: Example of a FLAC3D model.